2026-June-1 Service Incident

Update

We are continuing to investigate this issue.
Posted Jun 01, 2026 - 06:52 PDT

Investigating

We are experiencing an issue where the US-EAST data center is currently unavailable. We are investigating.
Posted Jun 01, 2026 - 06:48 PDT